Jump to content
Sign in to follow this  
drbubb

Imbedding YouTube Videos works differently in v-3.4.5

Recommended Posts

Imbedding YouTube Videos works differently in v-3.4.5

 

Bulletpoint:

===

If you submit a URL as a link, it remains a link. The problem is if we DON'T do that, then you can NEVER EVER submit a link to a youtube video, only the video.

If you want it to display as a video you have two options:

1) Do not let it be linked in the editor

2) Manually wrap in media tags

We have flipped back and forth on this bug report far too long. I do not intend to make any changes to this in 3.4.x.

===

/more: http://community.invisionpower.com/resources/bugs.html/_/ip-board/problem-with-embedded-content-displaying-as-links-after-upgrade-again-r42395#commentsStart

Share this post


Link to post
Share on other sites

IN other words...

 

I wanted THIS:

 

 

 

 

But instead, I got this : (but without the added ". . ." )

 

http://www.youtube . . . .com/ . . . watch?feature=player_embedded . . . &v=ykvRceBQRl8

 

Why?

 

Here's an example of the PURE LINK - no imbedded film:

 

 

(I am looking into the reasons... )

Share this post


Link to post
Share on other sites

Maybe this will work

 

EXAMPLE

 

<iframe width="640" height="390" src="//www.youtube.com/embed/xEhaVhta7sI" frameborder="0" allowfullscreen></iframe>

Share this post


Link to post
Share on other sites

IT's A BROWSER THING, it turns out...

 

I will second that, I want embedded as standard, not videos shown as links

You're not getting it.. this is a BROWSER problem and IPS can do nothing about it. When you paste a link in Chrome or IE the link gets automtically linked by the browser (so wrapped in a URL bbcode), instead when you paste the link in Firefox it doesn't get auto-linked (so not wrapped in any bbcode at all) and thus is gets properly parsed as a media bbcode (unless you manually wrap it with a URL bbcode).

 

If they make embedded as standard like you say then as Brandon mentioned it will be impossible to paste a youtube video link and have it show as a link only (for whatever reason you may need).

 

 

There are only 2 options at this point:

  • Complain to Chrome /IE to change this behavior tongue.png
  • Instruct your members using Chrome/IE to remove the link after pasting it
  • Well.. there's a 3rd option too: edit the source code yourself to change how media links are parsed

Share this post


Link to post
Share on other sites

Actually its easier. I am using Chrome. Just clicked the - share - button under the youtube vid and copied the link shown, post here, job done

 

The code you need to entered is only this.................http://youtu.be/PFU9HYyMVxQ.............................-without the dots

 

 

Am I dreaming or did a Moneyweek ad voiced by Frizzers just come up ? Hmm Google know too much.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×